SpinOffice is compatible for macOS Sierra


3rd October – We just want to inform all our users around the globe that SpinOffice CRM is now compatible for macOS Sierra, version 10.12.

If you use an earlier Mac version, don’t worry! SpinOffice supports older operating system versions, from OS X 10.7 Lion to OS X 10.11 El Capitan.


← Go to previous article | Go to main Blog page | Go to next article →